yum update не работает после установки панели

Обсуждение установки и настройки поддерживаемых вебсерверов, а также работы с ними.
Аватара пользователя
con
Сообщения: 57
Зарегистрирован: Вс мар 15, 2020 11:58 am

Re: yum update не работает после установки панели

Сообщение con » Сб май 02, 2020 7:06 pm

Еще раз апну. Тут кто-то есть живой, кто может помочь?
Centos7

Crazy Demon
Сообщения: 3
Зарегистрирован: Вт май 05, 2020 4:16 am

Re: yum update не работает после установки панели

Сообщение Crazy Demon » Вт май 05, 2020 5:34 am

тоже столкнулся с проблемой обновления.

Total 10 MB/s | 294 MB 00:00:28
Running transaction check
Running transaction test


Transaction check error:
file /usr/lib64/python2.7/site-packages/_yaml.so conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and PyYAML-3.10-11.el7.x86_64
file /usr/lib64/python2.7/site-packages/yaml/__init__.py conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and PyYAML-3.10-11.el7.x86_64
file /usr/lib64/python2.7/site-packages/yaml/__init__.pyc conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and
....
Error Summary
-------------

Полный лог в аттаче
yum_update_log.7z
yum_update_log.txt
(7.47 КБ) 35 скачиваний

Аватара пользователя
sbury
Сообщения: 622
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: yum update не работает после установки панели

Сообщение sbury » Вт май 05, 2020 9:25 am

Crazy Demon писал(а):
Вт май 05, 2020 5:34 am
тоже столкнулся с проблемой обновления.
Transaction check error:
file /usr/lib64/python2.7/site-packages/_yaml.so conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and PyYAML-3.10-11.el7.x86_64
file /usr/lib64/python2.7/site-packages/yaml/__init__.py conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and PyYAML-3.10-11.el7.x86_64
file /usr/lib64/python2.7/site-packages/yaml/__init__.pyc conflicts between attempted installs of python2-pyyaml-5.3-3.brainy.el7.x86_64 and
....
Error Summary
-------------
исправлено
yum clean all

volodyal
Сообщения: 11
Зарегистрирован: Вт сен 10, 2019 3:47 pm
Откуда: Україна

Re: yum update не работает после установки панели

Сообщение volodyal » Чт май 28, 2020 8:45 am

Доброго дня.
А что у моего VPN не так при yum update?
Спасибо за ответы!

Код: Выделить всё

Error: Package: 40:python3-bind-9.11.5-10.el7.noarch (brainy-python3_sb)
           Requires: bind-license = 40:9.11.5-10.el7
           Installed: 40:bind-license-9.11.1-7.P3.el7.centos.noarch (@myrepo-centos)
               bind-license = 40:9.11.1-7.P3.el7.centos
           Available: 32:bind-license-9.11.4-16.P2.el7.noarch (base)
               bind-license = 32:9.11.4-16.P2.el7
           Available: 32:bind-license-9.11.4-16.P2.el7_8.2.noarch (updates)
               bind-license = 32:9.11.4-16.P2.el7_8.2
           Available: 32:bind-license-9.11.4-16.P2.el7_8.3.noarch (updates)
               bind-license = 32:9.11.4-16.P2.el7_8.3
Error: Package: 40:bind-utils-9.11.1-7.P3.el7.centos.x86_64 (@myrepo-centos)
           Requires: python3-bind = 40:9.11.1-7.P3.el7.centos
           Removing: 40:python3-bind-9.11.1-7.P3.el7.centos.noarch (@myrepo-centos)
               python3-bind = 40:9.11.1-7.P3.el7.centos
           Updated By: 40:python3-bind-9.11.5-10.el7.noarch (brainy-python3_sb)
               python3-bind = 40:9.11.5-10.el7
           Available: 40:python3-bind-9.11.1-8.P3.el7.noarch (brainy-python3_sb)
               python3-bind = 40:9.11.1-8.P3.el7
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
fail2ban-0.9.7-10.el7.centos.noarch has missing requires of fail2ban-sendmail = ('0', '0.9.7', '10.el7.centos')
Прочитал всю ветку. Сделал все как советовали и писали разные люди - не помогло.

Ответить