Проблема с Chroot, помогите.

Обсуждение установки и настройки поддерживаемых вебсерверов, а также работы с ними.
Ответить
sh00r00p
Сообщения: 2
Зарегистрирован: Вт фев 04, 2020 6:26 am

Проблема с Chroot, помогите.

Сообщение sh00r00p » Вт фев 04, 2020 6:51 am

Есть сайт на bitrix. Сайт висит у пользователя в домашнем каталоге /home/user/
Решил поставить в битриксе модуль Ammina.Optimizer: для оптимизации сайта по pagespeed
У модуля множество библиотек, которые нужно по рекомендации разработчиков модуля установить на сервер. Вот эти пакеты https://www.ammina.ru/documentation/cou ... ON_PATH=97

Я все сделал по инструкции, из под root в ssh все поставил без ошибок.
Но модуль при проверки библиотек по началу не увидел.
Я так понял устанавливая из под root они устанавливались глобально, а модуль проверяет наличие установленных библиотек в среде user на актором находится сайт.
Я полез в Jali. Прописал пути
/usr/bin/jpegoptim
И тд по аналогии со всеми пакетами.
После перестроения jali skeleton пакеты скопировали в среду user и библиотеки модуль увидел.

Все бы хорошо, но один пакет он упорно не видит а именно yuicompressor
Как я понял у него скорей всего много зависимостей, Jre(Java) и тд. Как бы мне о них о всех узнать и заставить работать в среде user?
Или может есть вообще другой вариант какой то? Жду помощи...

sh00r00p
Сообщения: 2
Зарегистрирован: Вт фев 04, 2020 6:26 am

Re: Проблема с Chroot, помогите.

Сообщение sh00r00p » Вт фев 04, 2020 7:14 am

Может есть возможность установки не глобально, а локально сразу в среде пользователя? Но у пользователя так же нет прав на Sudo yum и другие команды.

Ответить