ffmpeg Нужна помощь

Обсуждение установки и настройки поддерживаемых вебсерверов, а также работы с ними.
yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

ffmpeg Нужна помощь

Сообщение yuloz » Чт мар 30, 2023 11:27 am

Всем привет
установлена панель BrainCP с модулем ffmpeg
но почему то он не работает(
ответ от разработчиков плагина -
It seems that FFmpeg is installed in the system, but it should be available for PHP as well. For this, you should edit the environment variables and add the FFmpeg path there. Then make sure it shows up in phpinfo (which can be viewed by installing a plugin).

как мне добавить путь и интегрировать в РНР
помогите!

Аватара пользователя
sbury
Сообщения: 1402
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: ffmpeg Нужна помощь

Сообщение sbury » Чт мар 30, 2023 1:40 pm

Какая установлена система и какую версию PHP используете? И можете более конкретно описать что именно не работает?

yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

Re: ffmpeg Нужна помощь

Сообщение yuloz » Чт мар 30, 2023 4:55 pm

Ubuntu 20.04
PHP 7.4
Apache2.4 + Nginx

Аватара пользователя
sbury
Сообщения: 1402
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: ffmpeg Нужна помощь

Сообщение sbury » Пт мар 31, 2023 5:26 am

Мы не видим никаких проблем с плагином

Код: Выделить всё

root@ub201:~# /usr/bin/php74/bin/php -ii | grep ffmpeg
/etc/php74w/php.d/40-ffmpeg.ini,
ffmpeg
ffmpeg-php version => 0.7.16
ffmpeg-php built on => Dec 25 2007 09:50:38
ffmpeg-php gd support  => enabled
ffmpeg libavcodec version => Lavc58.54.100
ffmpeg libavformat version => Lavf58.29.100
ffmpeg swscaler version => SwS5.5.100
ffmpeg.allow_persistent => 0 => 0
ffmpeg.show_warnings => 0 => 0
root@ub201:~#
Не очень понятно какому разработчику вы пишите и какие пути он советует прописать.

yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

Re: ffmpeg Нужна помощь

Сообщение yuloz » Пт мар 31, 2023 9:08 am

Получил ответ от разработчиков плагина (wordpress FS poster)

It is a PHP library that you downloaded to work with FFmpeg, but we need FFmpeg. If FFmpeg is installed then something like this should appear in phpinfo
https://prnt.sc/VhIlcZ78rp71
https://prnt.sc/19q8xzkbQOYk

These are visible to PHP as a result of the FFmpeg binaries being presented to the environment variables of the operating system.

ничего не понятно((

Аватара пользователя
sbury
Сообщения: 1402
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: ffmpeg Нужна помощь

Сообщение sbury » Пт мар 31, 2023 9:44 am

ну так сделайте любой скрипт на сайте

Код: Выделить всё

touch foo.php
с содержимым

Код: Выделить всё

<?php phpinfo(); ?>
загрузите его в браузере и проверьте поддержку модуля PHP ffmpeg

yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

Re: ffmpeg Нужна помощь

Сообщение yuloz » Пт мар 31, 2023 9:59 am

https://prnt.sc/kuGRwF2u2x0p

может проблема именно в плагине - а они мне лапшу вешают (
https://prnt.sc/UpbWJqb6HmJw
сейчас попробую на другом хостинге

Аватара пользователя
sbury
Сообщения: 1402
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: ffmpeg Нужна помощь

Сообщение sbury » Пт мар 31, 2023 10:43 am

а вы уточните у них версии плагинов, включая каккой им требуеся , и какая версия вордпресса?

yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

Re: ffmpeg Нужна помощь

Сообщение yuloz » Пт мар 31, 2023 10:44 am

На другом хостинге получаю

Error! FFmpeg Errors: ["Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height"], Command: "-y -i '/home/testffmp/site.com/www/wp-content/uploads/2023/03/pexels4434242-2160x3840-24fps.mp4' -vf 'crop=w=2160:h=2700:x=0:y=570' -metadata:s:v rotate="" -f mp4 -c:v libx264 -preset fast -crf 24 -strict -2 -c:a aac -b:a 96k -t 14.90 '/home/testffmp/.system/tmp/fs_6426b91e5e7fd.mp4'".

yuloz
Сообщения: 8
Зарегистрирован: Пн ноя 14, 2022 10:03 am

Re: ffmpeg Нужна помощь

Сообщение yuloz » Пт мар 31, 2023 10:44 am

sbury писал(а):
Пт мар 31, 2023 10:43 am
а вы уточните у них версии плагинов, включая каккой им требуеся , и какая версия вордпресса?
уточнял - все в порядке

Ответить