новый NodeJS v14.15 и phpХХ-v8js для CentOS 7/8

Ответить
Аватара пользователя
sbury
Сообщения: 796
Зарегистрирован: Вт фев 06, 2018 7:51 am

новый NodeJS v14.15 и phpХХ-v8js для CentOS 7/8

Сообщение sbury » Пн апр 05, 2021 9:51 am

Для 7 и 8 доступен новый NodeJS 14.15 с поддержкой libnode

Для установки дать команду с консоли
yum clean all
Дополнительно для CentOS 8 надо подать команду
yum -y module disable nodejs
и переустановить его в менеджере приложений
Если вы делаете новую установку, это делать не надо. Инсталлятор панели это сделает сам.

потом можно установить модули пхп v8js. Сейчас поддерживаются php71,72,73,74 для CentOS 7 и 8.
Можно установить через панель, можно с консоли. Например:
yum install php74w-v8js

одно важное замечание. модули v8js требуют наличие конкретной версии библиотеки libnode. Если вы устанавливали какойто свой nodejs, то модули v8js скорее всего работать не будут.

Ответить