Зависла переустановка proftpd

Все остальные вопросы
vikont
Сообщения: 219
Зарегистрирован: Сб ноя 11, 2017 10:51 pm

Re: Зависла переустановка proftpd

Сообщение vikont » Сб авг 03, 2019 10:10 pm

sbury писал(а):
Сб авг 03, 2019 6:12 pm
systemctl restart brainyphp-fpm
выполнил
sbury писал(а):
Сб авг 03, 2019 6:12 pm
и создайте пользователя еще раз
Ничего не появилось
sbury писал(а):
Сб авг 03, 2019 6:12 pm
здесь /etc/proftpd/ftpd.passwd информация о пользователе появляется?
Все в файле есть и никуда не девалось
sbury писал(а):
Сб авг 03, 2019 6:12 pm
и запустите скрипт на выполнение

/etc/brainy/ssh/check_pkg.sh -u auto
Запустил
[root@masterdnr sites]# /etc/brainy/ssh/check_pkg.sh -u auto

Starting the verification process
=================================

Update repository list... [OK]
Download pkgdb... [OK]
Check package CUnit... not installed
Check package Judy... not installed
Check package SDL2... pass (found 2.0.3-9)
Check package a52dec... not installed
Check package apr... not installed
Check package arts... not installed
Check package awstats... not installed
Check package brainy-php5... pass (found 5.6.40-1.5)
Check package brotli... pass (found 1.0.4-2)
Check package bind-libs... pass (found 9.10.7-4.P4)
Check package bind... pass (found 9.10.7-4.P4)
Check package clamav... not installed
Check package clang... not installed
Check package clang-libs... not installed
Check package dbus-c++... not installed
Check package dbus-c++-glib... not installed
Check package dhcp... not installed
Check package dhcp-libs... pass (found 4.2.5-72)
Check package dirac... not installed
Check package dirac-libs... not installed
Check package dovecot... not installed
Check package djvulibre... not installed
Check package djvulibre-libs... not installed
Check package eet... not installed
Check package evas... not installed
Check package exim... not installed
Check package faac... not installed
Check package fail2ban... not installed
Check package fdk-aac... pass (found 0.1.5-0.1.gita0bd8aa)
Check package ffmpeg... pass (found 3.2.2-2)
Check package ffmpeg-libs... pass (found 3.2.2-2)
Check package fftw... not installed
Check package firebird... not installed
Check package firebird-libfbclient... pass (found 2.5.5.26952.0-2)
Check package freetds... pass (found 0.95.81-1)
Check package gdk-pixbuf2... pass (found 2.36.12-6)
Check package glib... not installed
Check package glib2... FALSE (found 2.56.1-4.el7.centos, required = 2.56.1-10.el7.centos) {found new applicant repository: myrepo-centos}
Launching the remediation process for glib2... [OK]
Check package glib2... ok (found: 2.56.1-10)

Check package gmock... not installed
Check package gobject-introspection... pass (found 1.56.1-1)
Check package gtk+... not installed
Check package gtk3... not installed
Check package haveged... pass (found 1.9.1-9)
Check package imlib2... not installed
Check package iptraf-ng... not installed
Check package jack-audio-connection-kit... pass (found 1.9.10-6)
Check package jack-audio-connection-kit-dbus... not installed
Check package jailkit... pass (found 2.20-5)
Check package jemalloc... not installed
Check package kvazaar... not installed
Check package kvazaar-libs... pass (found 1.0.0-1)
Check package lame... not installed
Check package lame-libs... pass (found 3.99.5-6)
Check package libavdevice... pass (found 3.2.2-2)
Check package libc-client... pass (found 7.3-1)
Check package libcap... pass (found 2.25-10)
Check package libcdio... pass (found 0.94-1)
Check package libclc... not installed
Check package libcmocka... not installed
Check package libcurl... pass (found 7.60.0-1)
Check package libdb4... not installed
Check package libdc1394... pass (found 2.2.2-6)
Check package libdrm... pass (exclude, found 2.4.91-3.el7)
Check package libebur128... pass (found 1.2.2-1)
Check package libgsasl... pass (found 1.8.0-8)
Check package libidn2... pass (found 2.0.4-1)
Check package libmcrypt... pass (found 2.5.8-9)
Check package libmemcached... not installed
Check package libmemcached-libs... pass (found 1.0.18-10)
Check package libmetalink... pass (found 0.1.3-2)
Check package libmfx... pass (found 1.16-2.20160317git7adf2e4)
Check package libmikmod... not installed
Check package libmodplug... not installed
Check package libmp4v2... not installed
Check package libnghttp2... pass (found 1.31.1-1)
Check package libopendkim... pass (found 2.10.3-1)
Check package libopendmarc... pass (found 1.3.2-1)
Check package libpcap... not installed
Check package libsodium... pass (found 1.0.16-1)
Check package libspf2... pass (found 1.2.10-17)
Check package libssh... pass (found 0.7.4-1)
Check package libssh2... pass (found 1.8.0-5)
Check package libtidy... pass (found 0.99.0-31)
Check package libuv... not installed
Check package libva... pass (found 1.7.3-1)
Check package libwayland-client... pass (found 1.15.0-10)
Check package libwebp4... pass (found 0.3.0-7)
Check package libwebp... pass (found 0.6.0-2)
Check package libxkbcommon... not installed
Check package libxml++... pass (found 2.40.1-2)
Check package llvm... not installed
Check package llvm-libs... not installed
Check package lwp... not installed
Check package mhash... not installed
Check package mariadb-libs... pass (found 5.5.52-201)
Check package mesa-libEGL... A newer package is already installed. (found 18.0.5, outdated 17.3.8) ok
Check package mesa-libGL... A newer package is already installed. (found 18.0.5, outdated 17.3.8) ok
Check package net-snmp... pass (found 10.7.2-1)
Check package net-snmp-libs... pass (found 10.7.2-1)
Check package nghttp2... not installed
Check package nspr... pass (found 4.19.0-10)
Check package nss... pass (found 3.37.3-3)
Check package numactl... not installed
Check package numactl-libs... pass (found 2.0.9-100)
Check package nvenc... not installed
Check package ocl-icd... pass (found 2.2.9-2)
Check package openal-soft... pass (found 1.16.0-2)
Check package opendbx... pass (found 1.4.6-6)
Check package opendbx-mysql... not installed
Check package opendbx-sqlite... not installed
Check package opendkim... not installed
Check package opendmarc... not installed
Check package openh264-libs... pass (found 1.6.0-2)
Check package openjpeg2... not installed
Check package opus... pass (found 1.2-0.2)
Check package pcre2... pass (found 10.32-4)
Check package portaudio... not installed
Check package postgresql-libs... pass (found 9.6.5-1)
Check package potrace... not installed
Check package proftpd... pass (found 1.3.6-6.brainy.el7)
Check package psmisc... pass (found 23.1-2)
Check package pure-ftpd... not installed
Check package pyOpenSSL... not installed
Check package python34... not installed
Check package rarian... not installed
Check package re2c... not installed
Check package redis... not installed
Check package rhash... not installed
Check package rsync... pass (found 3.1.2-7)
Check package ruby... pass (found 2.4.0-76)
Check package ruby-libs... pass (found 2.4.0-76)
Check package rubygem-json... pass (found 2.0.2-76)
Check package rubygems... pass (found 2.6.8-76)
Check package rvm... not installed
Check package schroedinger... pass (found 1.0.11-4)
Check package scons... not installed
Check package shellinabox... pass (found 2.20-2)
Check package soxr... pass (found 0.1.1-3)
Check package speex... pass (found 1.2-0.25.rc2)
Check package speexdsp... not installed
Check package sscg... not installed
Check package tidy... not installed
Check package libtidy... pass (found 0.99.0-31)
Check package tslib... pass (found 1.0-9)
Check package turbojpeg... not installed
Check package twolame... not installed
Check package twolame-libs... pass (found 0.3.13-5)
Check package unixODBC... pass (found 2.3.1-11.el7)
Check package varnish... not installed
Check package varnish-libs... not installed
Check package vulkan... not installed
Check package wicd-gtk... not installed
Check package x264... not installed
Check package x264-libs... pass (found 0.148-6.20160912git3f5ed56)
Check package x265... not installed
Check package x265-libs... pass (found 2.2-1)
Check package xinetd... pass (found 2.3.15-134)
Check package xmms... not installed
Check package xvidcore... pass (found 1.3.2-6)
Check package yasm... not installed
Check package zlib... pass (found 1.2.11-8)
Check package zvbi... pass (found 0.2.35-1)
Check package libpq... not installed
Check package libmaxminddb... not installed
Check package zlib-devel... pass (found 1.2.11-8)
Check package nss-softokn-freebl... pass (found 3.37.3-3)
Check package nss-softokn-devel... not installed
Check package nss-softokn-freebl-devel... pass (found 3.37.3-3)
Check package shadow-utils... pass (found 4.1.5.1-62)

Total checked packages: 169
===========================
Total PASSED : 84
Total SKIPPED : 85
Total FAILED : 0
Total CHANGED : +1
-------------------------
Tests were successful!


Service test packages
=================================

Download pkgdb... [OK]
Check package clamd... not installed
Check package clamsmtp... not installed
Check package bind... pass (found 9.10.7-4.P4)
Check package dovecot... not installed
Check package exim... not installed
Check package pure-ftpd... not installed
Check package httpd24... FALSE (found 2.4.39-6.el7.centos, required = 2.4.39-7.el7.centos) {found new applicant repository: myrepo-centos}
update process is prohibited for httpd24!
Check package opendkim... not installed
Check package opendmarc... not installed
Check package mysql55... not installed
Check package mysql56... not installed
Check package mysql57... not installed
Check package mysql80... not installed
Check package mariadb10... not installed
Check package mariadb10.2... not installed
Check package mariadb10.3... pass (found 10.3.7-10)
Check package nginx... FALSE (found 1.16.0-3c.el7.centos, required = 1.16.0-6c.el7.centos) {found new applicant repository: myrepo-centos}
update process is prohibited for nginx!
Check package proftpd... pass (found 1.3.6-6.brainy.el7)
Check package memcached... not installed
Check package redis... not installed
Check package postgresql... pass (found 9.6.5-1)
Check package ffmpeg... pass (found 3.2.2-2)

Total checked packages: 22
===========================
Total PASSED : 5
Total SKIPPED : 15
Total FAILED : 2
Total CHANGED : +0
httpd24->(required:_2.4.39-7.el7.centos)
nginx->(required:_1.16.0-6c.el7.centos)
-------------------------
Fatal error. 2 packet(s) found does not match the stated.


Service test status
=================================

Test service clamd... not installed or not running
Test service named... pass
Test service dovecot... not installed or not running
Test service exim... not installed or not running
Test service pure-ftpd... not installed or not running
Test service httpd... not installed or not running
Test service opendkim... not installed or not running
Test service opendmarc... not installed or not running
Test service mysqld... pass
Test service nginx... pass
Test service spamassassin... not installed or not running
Test service proftpd... pass
Test service crond... pass
Test service csf... not installed or not running
Test service memcached... not installed or not running
Test service redis... not installed or not running
Test service postgresql... not installed or not running
Test service clamsmtp-clamd... not installed or not running
Test service clamsmtpd... not installed or not running

Total checked services: 19
===========================
Total PASSED : 5
Total SKIPPED : 14
Total FAILED : 0
Total CHANGED : +0
-------------------------
Tests were successful!

Продолжает крутиться Идет процесс

Аватара пользователя
sbury
Сообщения: 521
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Зависла переустановка proftpd

Сообщение sbury » Вс авг 04, 2019 8:03 am

запустите простой ftp клиент

yum install ftp

ftp IP

логин пароль проходит?

vikont
Сообщения: 219
Зарегистрирован: Сб ноя 11, 2017 10:51 pm

Re: Зависла переустановка proftpd

Сообщение vikont » Вс авг 04, 2019 9:50 am

sbury писал(а):
Вс авг 04, 2019 8:03 am
запустите простой ftp клиент

yum install ftp

ftp IP

логин пароль проходит?
Нет, тоже не пускает, видимо незавершенность процесса не дает допуска
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

Аватара пользователя
sbury
Сообщения: 521
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Зависла переустановка proftpd

Сообщение sbury » Вс авг 04, 2019 10:02 am

попробуйте перебить в ручную

ftpasswd --passwd --name=userftp --change-password

нажмите в панели где устанавливается ftp кнопку показать лог последней установки и покажите скриншот окна лога

проверьте в /etc/proftpd.conf строки

RequireValidShell off
AuthUserFile /etc/proftpd/ftpd.passwd
QuotaEngine on
QuotaLimitTable file:/etc/proftpd/ftpquota.limittab
QuotaTallyTable file:/etc/proftpd/ftpquota.tallytab
QuotaDisplayUnits "Mb"
#AuthPAM off

и здесь /etc/brainy/data/users_ftp информация о ваших ftp клиентах есть?

vikont
Сообщения: 219
Зарегистрирован: Сб ноя 11, 2017 10:51 pm

Re: Зависла переустановка proftpd

Сообщение vikont » Вс авг 04, 2019 12:10 pm

sbury писал(а):
Вс авг 04, 2019 10:02 am
попробуйте перебить в ручную

ftpasswd --passwd --name=userftp --change-password
sbury писал(а):
Вс авг 04, 2019 10:02 am
нажмите в панели где устанавливается ftp кнопку показать лог последней установки и покажите скриншот окна лога
Нет кнопки. Все то же что на картинке выше только без кнопки логов.
sbury писал(а):
Вс авг 04, 2019 10:02 am
проверьте в /etc/proftpd.conf строки

RequireValidShell off
AuthUserFile /etc/proftpd/ftpd.passwd
QuotaEngine on
QuotaLimitTable file:/etc/proftpd/ftpquota.limittab
QuotaTallyTable file:/etc/proftpd/ftpquota.tallytab
QuotaDisplayUnits "Mb"
#AuthPAM off
Отсутствуют полностью. Куда их прописывать?
sbury писал(а):
Вс авг 04, 2019 10:02 am
и здесь /etc/brainy/data/users_ftp информация о ваших ftp клиентах есть?
Все есть, но если пароли должны совпадать с прописанными здесь /etc/proftpd/ftpd.passwd то не совпадают.

Аватара пользователя
sbury
Сообщения: 521
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Зависла переустановка proftpd

Сообщение sbury » Вс авг 04, 2019 3:45 pm

cat /etc/brainy/data/packet_manager2/main

vikont
Сообщения: 219
Зарегистрирован: Сб ноя 11, 2017 10:51 pm

Re: Зависла переустановка proftpd

Сообщение vikont » Вс авг 04, 2019 5:58 pm

sbury писал(а):
Вс авг 04, 2019 3:45 pm
cat /etc/brainy/data/packet_manager2/main
Выполнил, получил статусы, в остальном ничего не изменилось

[root@masterdnr ~]# cat /etc/brainy/data/packet_manager2/main
status_ftp=inprogress,packet_manager2_control_156449614360802
ftp=1
ftp_version=proftpd
status_mysql=success,packet_manager2_create_stream_online_155949413246919
mysql=1
mysql_version=MariaDB10.3
status_phpmyadmin=success,packet_manager2_create_stream_online_155949440150758
phpmyadmin=1
phpmyadmin_version=phpMyAdmin-4.8.0.1
status_ffmpeg=success,packet_manager2_create_stream_online_155949466117100
ffmpeg=1
status_imagemagick=unsuccess,packet_manager2_create_stream_online_155949469079694
status_certbot=success,packet_manager2_create_stream_online_155949469348769
certbot=1
status_logrotate=unsuccess,packet_manager2_create_stream_online_155949515837242
status_shellinabox=success,packet_manager2_create_stream_online_155949516127410
shellinabox=1
status_exim=success,packet_manager2_control_155949744733368
exim=0
status_opendkim=success,packet_manager2_control_155949714617951
opendkim=0
status_opendmarc=success,packet_manager2_control_155949717765364
opendmarc=0
status_dovecot=success,packet_manager2_control_155949724255775
status_squirrelmail=success,packet_manager2_control_155949727523805
squirrelmail=0
dovecot=0
status_fail2ban=success,packet_manager2_control_155949733852257
fail2ban=1
status_named=success,packet_manager2_control_156279113548574

Аватара пользователя
sbury
Сообщения: 521
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Зависла переустановка proftpd

Сообщение sbury » Пн авг 05, 2019 7:10 am

заменить

status_ftp=inprogress,packet_manager2_control_156449614360802

на

status_ftp=success,packet_manager2_control_156449614360802

зайти заново в панель и переустановить в нем ftp

vikont
Сообщения: 219
Зарегистрирован: Сб ноя 11, 2017 10:51 pm

Re: Зависла переустановка proftpd

Сообщение vikont » Пн авг 05, 2019 7:57 am

sbury писал(а):
Пн авг 05, 2019 7:10 am
заменить

status_ftp=inprogress,packet_manager2_control_156449614360802

на

status_ftp=success,packet_manager2_control_156449614360802

зайти заново в панель и переустановить в нем ftp
УРА! ЗАРАБОТАЛО! (@Кот Матроскин) :)

ПС.: Для тех кто не в курсе, менять надо здесь /etc/brainy/data/packet_manager2/main

Аватара пользователя
sbury
Сообщения: 521
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Зависла переустановка proftpd

Сообщение sbury » Пн авг 05, 2019 2:00 pm

да, есть проблема при смене старой версии на новую. Подкорректируем скрипт установки в ближайшем обновлении, что бы он учитывал этот момент. При установке уже новой или его переустановке такая проблема не наблюдается.

Ответить