Ошибка при установке

Все остальные вопросы
ershot
Сообщения: 3
Зарегистрирован: Вт янв 07, 2020 12:04 am

Re: Ошибка при установке

Сообщение ershot » Вт янв 07, 2020 12:44 am

Панель установилась, проблема была в том что не хватало места на разделе. Установка панели заняла 5.1Gb

ershot
Сообщения: 3
Зарегистрирован: Вт янв 07, 2020 12:04 am

Re: Ошибка при установке

Сообщение ershot » Вт янв 07, 2020 12:47 am

ershot писал(а):
Вт янв 07, 2020 12:09 am
nikservice писал(а):
Сб июн 01, 2019 12:01 pm
Доброго времени суток!
Устанавливаю всё по мануалу на Centos 7. Всё проходит ровно. В конце появляется
BRAINY Prepare configure 1... [ERROR]
И появляется курсор консоли. После перезагрузки, как ни странно, всё запускается и вроде бы работает. Я что-то теряю из-за этой ошибки? И что это вообще такое?
У меня такая же проблема, устанавливал сразу после установки и эта же ошибка BRAINY Prepare configure 1... [ERROR]
Пробовал установить после обновления CentOS7 но так же ошибка.
Есть решение что делать, панель работает вроде но не должно же так быть.
Спасибо
Панель установилась, проблема в том что раздела в 2-3Gb как написано в мануале не хватило. После установки панель заняла 5.1Gb

Prosto
Сообщения: 5
Зарегистрирован: Пт июн 05, 2020 1:34 am

Re: Ошибка при установке

Сообщение Prosto » Пт июн 05, 2020 1:58 am

Здравствуйте,

Аналогичная ошибка в конце установки. OS CentOS 7 x64.

# virt-what # systemctl status polkit -l

Код: Выделить всё

● polkit.service - Authorization Manager
   Loaded: loaded (/usr/lib/systemd/system/polkit.service; static; vendor preset: enabled)
   Active: active (running) since Wed 2020-06-03 18:59:00 MSK; 1 day 9h ago
     Docs: man:polkit(8)
 Main PID: 1267 (polkitd)
   CGroup: /system.slice/polkit.service
           └─1267 /usr/lib/polkit-1/polkitd --no-debug
# df -h

Код: Выделить всё

Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        221M     0  221M   0% /dev
tmpfs           244M     0  244M   0% /dev/shm
tmpfs           244M   33M  211M  14% /run
tmpfs           244M     0  244M   0% /sys/fs/cgroup
/dev/sda1        10G  4.7G  5.4G  47% /
tmpfs            49M     0   49M   0% /run/user/0

Аватара пользователя
sbury
Сообщения: 605
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Ошибка при установке

Сообщение sbury » Пт июн 05, 2020 8:15 am

покажите вывод
cat /install_0.log

Prosto
Сообщения: 5
Зарегистрирован: Пт июн 05, 2020 1:34 am

Re: Ошибка при установке

Сообщение Prosto » Сб июн 06, 2020 4:09 am

cat /install_0.log
Часть 1.

Код: Выделить всё

Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: mirrors.datahouse.ru
 * extras: mirrors.datahouse.ru
 * updates: mirrors.datahouse.ru
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:1.18.4-3.el7 will be installed
--> Processing Dependency: NetworkManager-libnm(x86-64) = 1:1.18.4-3.el7 for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_8_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_6_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_4_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_2_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_18_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_16_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_14_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_12_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_10_2)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_10_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_0_0)(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
--> Processing Dependency: libnm.so.0()(64bit) for package: 1:NetworkManager-1.18.4-3.el7.x86_64
---> Package NetworkManager-team.x86_64 1:1.18.4-3.el7 will be installed
---> Package NetworkManager-tui.x86_64 1:1.18.4-3.el7 will be installed
---> Package NetworkManager-wifi.x86_64 1:1.18.4-3.el7 will be installed
--> Running transaction check
---> Package NetworkManager-libnm.x86_64 1:1.18.4-3.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch         Version               Repository  Size
================================================================================
Installing:
 NetworkManager             x86_64       1:1.18.4-3.el7        base       1.9 M
 NetworkManager-team        x86_64       1:1.18.4-3.el7        base       164 k
 NetworkManager-tui         x86_64       1:1.18.4-3.el7        base       327 k
 NetworkManager-wifi        x86_64       1:1.18.4-3.el7        base       201 k
Installing for dependencies:
 NetworkManager-libnm       x86_64       1:1.18.4-3.el7        base       1.7 M

Transaction Summary
================================================================================
Install  4 Packages (+1 Dependent package)

Total download size: 4.2 M
Installed size: 14 M
Downloading packages:
--------------------------------------------------------------------------------
Total                                              913 kB/s | 4.2 MB  00:04
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : 1:NetworkManager-libnm-1.18.4-3.el7.x86_64                   1/5
  Installing : 1:NetworkManager-1.18.4-3.el7.x86_64                         2/5
  Installing : 1:NetworkManager-tui-1.18.4-3.el7.x86_64                     3/5
  Installing : 1:NetworkManager-team-1.18.4-3.el7.x86_64                    4/5
  Installing : 1:NetworkManager-wifi-1.18.4-3.el7.x86_64                    5/5
  Verifying  : 1:NetworkManager-tui-1.18.4-3.el7.x86_64                     1/5
  Verifying  : 1:NetworkManager-1.18.4-3.el7.x86_64                         2/5
  Verifying  : 1:NetworkManager-team-1.18.4-3.el7.x86_64                    3/5
  Verifying  : 1:NetworkManager-wifi-1.18.4-3.el7.x86_64                    4/5
  Verifying  : 1:NetworkManager-libnm-1.18.4-3.el7.x86_64                   5/5

Installed:
  NetworkManager.x86_64 1:1.18.4-3.el7
  NetworkManager-team.x86_64 1:1.18.4-3.el7
  NetworkManager-tui.x86_64 1:1.18.4-3.el7
  NetworkManager-wifi.x86_64 1:1.18.4-3.el7

Dependency Installed:
  NetworkManager-libnm.x86_64 1:1.18.4-3.el7

Complete!
warning: file /var/lib/rpcbind: remove failed: No such file or directory
rpm: no packages given for erase
rpm: no packages given for erase
rpm: no packages given for erase
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package openssl.x86_64 1:1.0.2k-19.el7 will be updated
---> Package openssl.x86_64 1:1.0.2r-18.el7 will be an update
---> Package openssl-devel.x86_64 1:1.0.2r-18.el7 will be installed
--> Processing Dependency: zlib-devel(x86-64) for package: 1:openssl-devel-1.0.2r-18.el7.x86_64
---> Package openssl-libs.x86_64 1:1.0.2k-19.el7 will be updated
---> Package openssl-libs.x86_64 1:1.0.2r-18.el7 will be an update
--> Running transaction check
---> Package zlib-devel.x86_64 0:1.2.11-8.el7.centos will be installed
--> Processing Dependency: zlib(x86-64) = 1.2.11-8.el7.centos for package: zlib-devel-1.2.11-8.el7.centos.x86_64
--> Running transaction check
---> Package zlib.x86_64 0:1.2.7-18.el7 will be updated
---> Package zlib.x86_64 0:1.2.11-8.el7.centos will be an update
--> Finished Dependency Resolution

Prosto
Сообщения: 5
Зарегистрирован: Пт июн 05, 2020 1:34 am

Re: Ошибка при установке

Сообщение Prosto » Сб июн 06, 2020 4:17 am

Часть 2.

Код: Выделить всё

Dependencies Resolved

================================================================================
 Package           Arch       Version              Repository         Size
================================================================================
Installing:
openssl-devel  x86_64   1:1.0.2r-18.el7   myrepo-centos     1.5 M
Updating:
openssl    x86_64   1:1.0.2r-18.el7   myrepo-centos  504 k
openssl-libs   x86_64  1:1.0.2r-18.el7  myrepo-centos  1.2 M
Installing for dependencies:
zlib-devel  x86_64  1.2.11-8.el7.centos   myrepo-centos   40 k
Updating for dependencies:
zlib  x86_64  1.2.11-8.el7.centos  myrepo-centos  84 k

Transaction Summary
================================================================================
Install  1 Package  (+1 Dependent package)
Upgrade  2 Packages (+1 Dependent package)

Total download size: 3.4 M
Downloading packages:
No Presto metadata available for myrepo-centos
--------------------------------------------------------------------------------
Total                                           899 kB/s | 3.4 MB  00:03
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : zlib-1.2.11-8.el7.centos.x86_64                     1/8
  Updating   : 1:openssl-libs-1.0.2r-18.el7.x86_64                2/8
  Installing : zlib-devel-1.2.11-8.el7.centos.x86_64              3/8
  Installing : 1:openssl-devel-1.0.2r-18.el7.x86_64               4/8
  Updating   : 1:openssl-1.0.2r-18.el7.x86_64                       5/8
  Cleanup    : 1:openssl-1.0.2k-19.el7.x86_64                       6/8
  Cleanup    : 1:openssl-libs-1.0.2k-19.el7.x86_64                 7/8
  Cleanup    : zlib-1.2.7-18.el7.x86_64                                 8/8
  Verifying  : zlib-devel-1.2.11-8.el7.centos.x86_64              1/8
  Verifying  : 1:openssl-1.0.2r-18.el7.x86_64                        2/8
  Verifying  : 1:openssl-devel-1.0.2r-18.el7.x86_64               3/8
  Verifying  : 1:openssl-libs-1.0.2r-18.el7.x86_64                  4/8
  Verifying  : zlib-1.2.11-8.el7.centos.x86_64                       5/8
  Verifying  : 1:openssl-libs-1.0.2k-19.el7.x86_64                  6/8
  Verifying  : 1:openssl-1.0.2k-19.el7.x86_64                       7/8
  Verifying  : zlib-1.2.7-18.el7.x86_64                                  8/8

Installed:
  openssl-devel.x86_64 1:1.0.2r-18.el7

Dependency Installed:
  zlib-devel.x86_64 0:1.2.11-8.el7.centos

Updated:
  openssl.x86_64 1:1.0.2r-18.el7       openssl-libs.x86_64 1:1.0.2r-18.el7

Dependency Updated:
  zlib.x86_64 0:1.2.11-8.el7.centos

Complete!
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.datahouse.ru
 * extras: mirrors.datahouse.ru
 * updates: mirrors.datahouse.ru
Resolving Dependencies
--> Running transaction check
---> Package haveged.x86_64 0:1.9.1-9.el7.centos will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch         Version                   Repository           Size
================================================================================
Installing:
 haveged       x86_64       1.9.1-9.el7.centos        myrepo-centos        58 k

Transaction Summary
================================================================================
Install  1 Package

Total download size: 58 k
Installed size: 185 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : haveged-1.9.1-9.el7.centos.x86_64                            1/1
  Verifying  : haveged-1.9.1-9.el7.centos.x86_64                            1/1

Installed:
  haveged.x86_64 0:1.9.1-9.el7.centos

Complete!
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages database in /var/lib/rpm
error: package dhclient is not installed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed

Аватара пользователя
sbury
Сообщения: 605
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Ошибка при установке

Сообщение sbury » Сб июн 06, 2020 10:30 am

Prosto писал(а):
Сб июн 06, 2020 4:17 am


Error: rpmdb open failed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 - (-30973)
error: cannot open Packages database in /var/lib/rpm
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages database in /var/lib/rpm
error: package dhclient is not installed
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 - (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed[/code]
у вас развалилась база rpm пакетов. Обычно это из-за недостатка места на винте.

покажите выводы этих команд:
uname -r
rpm -qa | grep glibc
df

Prosto
Сообщения: 5
Зарегистрирован: Пт июн 05, 2020 1:34 am

Re: Ошибка при установке

Сообщение Prosto » Сб июн 06, 2020 5:20 pm

# uname -r

Код: Выделить всё

3.10.0-1127.8.2.el7.x86_64
# rpm -qa | grep glibc

Код: Выделить всё

error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
error: rpmdb: BDB0113 Thread/process 26778/139999049914176 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages database in /var/lib/rpm
# df

Код: Выделить всё

Filesystem     1K-blocks    Used Available Use% Mounted on
devtmpfs          225392       0    225392   0% /dev
tmpfs             249300       0    249300   0% /dev/shm
tmpfs             249300   33272    216028  14% /run
tmpfs             249300       0    249300   0% /sys/fs/cgroup
/dev/sda1       10474476 4872992   5601484  47% /
tmpfs              49864       0     49864   0% /run/user/0

Аватара пользователя
sbury
Сообщения: 605
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Ошибка при установке

Сообщение sbury » Вс июн 07, 2020 12:15 pm

места вроде достаточно. Возможно проблемы с накопителем. Свяжитесь с нами в рабочее время по чату или скайпу. Посмотрим что не так

Prosto
Сообщения: 5
Зарегистрирован: Пт июн 05, 2020 1:34 am

Re: Ошибка при установке

Сообщение Prosto » Вт июн 09, 2020 12:34 pm

Спасибо большое. С удовольствием. Связался с вами в чате.

Ответить