phpMyAdmin 5.0.0 for PHP 7.1.3

Обсуждение установки и настройки поддерживаемых серверов баз данных, а также работы с ними.
Олег55
Сообщения: 21
Зарегистрирован: Ср янв 01, 2020 6:39 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение Олег55 » Ср янв 08, 2020 12:38 pm

Вопрос: обновил phpmyadmin до 5 версии через панель, установил php7.1 тоже через панель а phpmyadmin выдает это PHP 7.1.3+ is required.
Currently installed version is: 5.6.40

Как быть и что не так я сделал???

Аватара пользователя
KyKyIIIKuH
Сообщения: 129
Зарегистрирован: Ср мар 14, 2018 11:04 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение KyKyIIIKuH » Ср янв 08, 2020 12:52 pm

Олег55 писал(а):
Ср янв 08, 2020 12:38 pm
Вопрос: обновил phpmyadmin до 5 версии через панель, установил php7.1 тоже через панель а phpmyadmin выдает это PHP 7.1.3+ is required.
Currently installed version is: 5.6.40

Как быть и что не так я сделал???
ответ находится на 1 странице данной темы.
почитайте пожалуйста внимательно.

Спасибо :roll:

Олег55
Сообщения: 21
Зарегистрирован: Ср янв 01, 2020 6:39 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение Олег55 » Ср янв 08, 2020 1:24 pm

KyKyIIIKuH писал(а):
Ср янв 08, 2020 12:52 pm
ответ находится на 1 странице данной темы.
почитайте пожалуйста внимательно.
Вы не поверите, я читал ни не раз!
Вы предложили откатится на старую версию
KyKyIIIKuH писал(а):
Пт янв 03, 2020 7:22 pm
откатывай версию phpmyadmin
Но мне нужна php7.1 и выше как минимум 7.2 что бы я мог движок форума обновить до новой версии.
пользователь ordex вообще предложил это
ordex писал(а):
Ср янв 08, 2020 11:10 am
Если "ну очень нужно", то скачайте нужную версию phpmyadmin и закиньте в папку с сайтом под php 7
Спрашивается зачем мне скачивать дополнительно phpmyadmin и копировать в папку когда панель и так обновляет ее.

Только вопрос сам собой возникает, если панель обновляет phpmyadmin но при этом устанавливает по умолчанию php5.6, и при этом при установке php7 и выше версии через панель остается все также php5.6, тогда зачем все установки других версий php если они не включаются, так для понтов что ли, я вот честно не пойму.
P/S Извините конечно может я грубо ответил вам, просто весь день на это убил, а оказывается зря!!!

Аватара пользователя
alenka
Сообщения: 458
Зарегистрирован: Ср сен 27, 2017 11:10 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение alenka » Ср янв 08, 2020 1:55 pm

Но мне нужна php7.1 и выше как минимум 7.2
Сама панель работает только на версии php5.6, и для данной версии максимум phpMyAdmin-4.9.4, сами сайты могут работать на любой версии php.

Аватара пользователя
ordex
Сообщения: 257
Зарегистрирован: Вт ноя 20, 2018 2:47 pm

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение ordex » Ср янв 08, 2020 1:58 pm

Олег55 писал(а):
Ср янв 08, 2020 1:24 pm
Только вопрос сам собой возникает, если панель обновляет phpmyadmin но при этом устанавливает по умолчанию php5.6, и при этом при установке php7 и выше версии через панель остается все также php5.6, тогда зачем все установки других версий php если они не включаются, так для понтов что ли, я вот честно не пойму.
P/S Извините конечно может я грубо ответил вам, просто весь день на это убил, а оказывается зря!!!
Писали же уже, что в обновлении вернут максимальную для 5.6 версию. Если вам нужен phpmyadmin под php7 (зачем?!), то без вариантов, только то, что я предложил т.к. панель работает на php5, вроде понятно должно быть, в чем сложность то.

Олег55
Сообщения: 21
Зарегистрирован: Ср янв 01, 2020 6:39 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение Олег55 » Ср янв 08, 2020 2:17 pm

ordex писал(а):
Ср янв 08, 2020 1:58 pm
Если вам нужен phpmyadmin под php7 (зачем?!),
Я уже сообщал.
Олег55 писал(а):
Ср янв 08, 2020 1:24 pm
Но мне нужна php7.1 и выше как минимум 7.2 что бы я мог движок форума обновить до новой версии.
Мне нужно еще и phpmyadmin с php7 что бы я мог базу данных обновить а иначе ни как.
Обязательные системные требования для установки phpBB 3.3.x:

Вебсервер под управлением любой операционной системы с поддержкой PHP
Сервер SQL, список поддерживаемых:
MySQL 4.1.3 и выше (MySQLi)
MariaDB 5.1 и выше
PostgreSQL 8.3+
SQLite 3.6.15+
MS SQL Server 2000 и выше (прямое подключение, либо через ODBC или нативный драйвер)
Oracle
PHP 7.1 - 7.4 с поддержкой используемой СУБД.
Обязательные модули PHP:
json
поддержка XML
Наличие следующих модулей PHP позволит получить дополнительные возможности (не обязательны):
Поддержка сжатия zlib
Поддержка удаленного доступа к FTP
Модуль GD
ordex писал(а):
Ср янв 08, 2020 1:58 pm
то без вариантов
Плохо :( , что я еще могу сказать.
ordex писал(а):
Ср янв 08, 2020 1:58 pm
только то, что я предложил
По подробней можете описать как это сделать.

Аватара пользователя
ordex
Сообщения: 257
Зарегистрирован: Вт ноя 20, 2018 2:47 pm

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение ordex » Ср янв 08, 2020 2:22 pm

Олег55 писал(а):
Ср янв 08, 2020 2:17 pm
ordex писал(а):
Ср янв 08, 2020 1:58 pm
Если вам нужен phpmyadmin под php7 (зачем?!),
Я уже сообщал.
Олег55 писал(а):
Ср янв 08, 2020 1:24 pm
Но мне нужна php7.1 и выше как минимум 7.2 что бы я мог движок форума обновить до новой версии.
Мне нужно еще и phpmyadmin с php7 что бы я мог базу данных обновить а иначе ни как.
Обязательные системные требования для установки phpBB 3.3.x:

Вебсервер под управлением любой операционной системы с поддержкой PHP
Сервер SQL, список поддерживаемых:
MySQL 4.1.3 и выше (MySQLi)
MariaDB 5.1 и выше
PostgreSQL 8.3+
SQLite 3.6.15+
MS SQL Server 2000 и выше (прямое подключение, либо через ODBC или нативный драйвер)
Oracle
PHP 7.1 - 7.4 с поддержкой используемой СУБД.
Обязательные модули PHP:
json
поддержка XML
Наличие следующих модулей PHP позволит получить дополнительные возможности (не обязательны):
Поддержка сжатия zlib
Поддержка удаленного доступа к FTP
Модуль GD
ordex писал(а):
Ср янв 08, 2020 1:58 pm
то без вариантов
Плохо :( , что я еще могу сказать.
ordex писал(а):
Ср янв 08, 2020 1:58 pm
только то, что я предложил
По подробней можете описать как это сделать.
Кто-то из нас двоих чего-то не понимает. Давайте ещё раз. Phpmyadmin работает "из-под панели" которая использует 5.6, при этом вы работаете с бд сайтов которые в свою очередь работают под любой версией php. Я в вашем тексте нигде не увидел, что вашему phpbb требуется phpmyadmin работающий под 7.x

Олег55
Сообщения: 21
Зарегистрирован: Ср янв 01, 2020 6:39 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение Олег55 » Ср янв 08, 2020 2:35 pm

может я что то не понимаю, но вот это PHP 7.1 - 7.4 с поддержкой используемой СУБД вам ни о чем не говорит, если я не прав то поправьте меня, СУБД- это система управления базами данных которая должна поддерживать PHP 7.1 - 7.4, а базу данных я должен импортировать через phpmyadmin, а отсюда вывод, что phpmyadmin должна быть с установленным PHP 7.1 - 7.4

Аватара пользователя
ordex
Сообщения: 257
Зарегистрирован: Вт ноя 20, 2018 2:47 pm

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение ordex » Ср янв 08, 2020 2:38 pm

Олег55 писал(а):
Ср янв 08, 2020 2:35 pm
может я что то не понимаю, но вот это PHP 7.1 - 7.4 с поддержкой используемой СУБД вам ни о чем не говорит, если я не прав то поправьте меня, СУБД- это система управления базами данных которая должна поддерживать PHP 7.1 - 7.4, а базу данных я должен импортировать через phpmyadmin, а отсюда вывод, что phpmyadmin должна быть с установленным PHP 7.1 - 7.4
Вывод неправильный, вы можете импортировать хоть из командной строки или из adminer или из любой другой морды к mysql, без разницы. Ставьте со спокойной душой через тот phpmyadmin который есть, для сайта поставьте нужную версию (7.1-7.4) и будет вам счастье.

Олег55
Сообщения: 21
Зарегистрирован: Ср янв 01, 2020 6:39 am

Re: phpMyAdmin 5.0.0 for PHP 7.1.3

Сообщение Олег55 » Ср янв 08, 2020 2:49 pm

Хорошо, попробую, но что то мне подсказывает, что не пройдет данная фишка.

Ответить