MySQL не работает, но этого не видно

Обсуждение установки и настройки поддерживаемых серверов баз данных, а также работы с ними.
dmitry_stas
Сообщения: 177
Зарегистрирован: Вт апр 17, 2018 7:43 am

Re: MySQL не работает, но этого не видно

Сообщение dmitry_stas » Вт апр 23, 2019 7:51 am

в общем, что удалось выяснить. получается что после перезагрузки сервера запускался не mysqld.service, а mariadb.service. соотвественно, mysqld.service уже не мог запустится, что и было видно в панели, и попытки старта из панели тоже ни к чему не приводили. но вот вопрос - а почему собственно запускался mariadb.service? ведь как видно в выводе
# systemctl status mariadb
● mariadb.service - MariaDB 10.3.7 database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor pre set: disabled)
его автозапуск отключен. что в таком случае его может стартовать?

что интересно, у mysqld тоже был отключен автозапуск
# systemctl status mysqld
● mysqld.service - MariaDB 10.3 database server
Loaded: loaded (/usr/lib/systemd/system/mysqld.service; disabled; vendor pres et: disabled)
и проверил на другом сервере, там тоже самое, автозапуск для mysqld отключен. я кстати уже писал когда то об этой проблеме, что база не стартует автоматом, и ее подымает только монитор сервисов.

включил автозапуск для mysqld, пару раз перегрузил сервер - после перезагрузки mysqld запущен. понаблюдаю еще, но вроде бы пока все норм.

остался один вопрос - почему на втором сервере в Мониторинг сервисов отсутствует Mysql - https://prnt.sc/netdax ? как мне ее туда добавить?

Аватара пользователя
alenka
Сообщения: 377
Зарегистрирован: Ср сен 27, 2017 11:10 am

Re: MySQL не работает, но этого не видно

Сообщение alenka » Вт апр 23, 2019 9:04 am

Добавим mysqld в автозапуск, и мониторинг сервисов - уже проверяем.

Аватара пользователя
alenka
Сообщения: 377
Зарегистрирован: Ср сен 27, 2017 11:10 am

Re: MySQL не работает, но этого не видно

Сообщение alenka » Вт апр 23, 2019 12:43 pm

Автозапуск для мускула поправили, и мониторинг сервисов. Ожидайте в обновлении.
До обновления можно отредактировать /etc/brainy/data/monitor/data_s
lang.mysql_dbservice заменить на lang.mysql

Ответить