Mariadb 10.5 отсутствует для установки

Обсуждение установки и настройки поддерживаемых серверов баз данных, а также работы с ними.
Ответить
stargys
Сообщения: 5
Зарегистрирован: Пн мар 29, 2021 9:44 am

Mariadb 10.5 отсутствует для установки

Сообщение stargys » Вт апр 27, 2021 8:14 pm

Всем привет!

У меня есть 2 vps с brainy, свежий сервер и старый.
Обратил внимание, что на новом есть возможность установки mariadb 10.5, а так же веб-сервера nginx_apache_nodejs.
На старом этого нет, хотя я обновился до последней версии. Yum update и yum clean all эффекта не дали.
Что я могу еще предпринять, чтобы появились эти возможности на старом vps?

Спасибо!

Аватара пользователя
alenka
Сообщения: 647
Зарегистрирован: Ср сен 27, 2017 11:10 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение alenka » Ср апр 28, 2021 7:11 am

Панель версии 1.08 не поддерживает maria10.5, ожидайте обновление на панель версии 1.09

stargys
Сообщения: 5
Зарегистрирован: Пн мар 29, 2021 9:44 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение stargys » Ср апр 28, 2021 10:01 pm

Благодарю за оперативное решение!

Ребята, вы немного поспешили с обновлением.
→ Не устанавливается certbot. После нажатия на кнопку "Установка", она становится неактивной на 5-10 секунд и возвращается в исходное состояние. Проверил также на чистом vps с brainycp.
→ NodeJS в сборке веб-сервера Apache+Nginx не появился. Бог с ним. Но после обновы отвалился Nginx.

Код: Выделить всё

Перезапуск неуспешный. Сервис не работает.
nginx.service - The nginx HTTP and reverse proxy server
Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2021-04-29 00:58:54 MSK; 13ms ago
Process: 16608 ExecReload=/bin/kill -s HUP $MAINPID (code=exited, status=0/SUCCESS)
Process: 27081 ExecStartPre=/usr/sbin/nginx -t (code=exited, status=1/FAILURE)
Process: 27079 ExecStartPre=/usr/bin/rm -f /run/nginx.pid (code=exited, status=0/SUCCESS)
Main PID: 13673 (code=exited, status=0/SUCCESS)

Apr 29 00:58:54 domain.co systemd[1]: Starting The nginx HTTP and reverse proxy server...
Apr 29 00:58:54 domain.co nginx[27081]: nginx: [emerg] cannot load certificate "/etc/brainy/src/ssl/webserver.crt": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/etc/brainy/src/ssl/webserver.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)
Apr 29 00:58:54 domain.co nginx[27081]: nginx: configuration file /etc/nginx/nginx.conf test failed
Apr 29 00:58:54 domain.co systemd[1]: nginx.service: control process exited, code=exited status=1
Apr 29 00:58:54 domain.co systemd[1]: Failed to start The nginx HTTP and reverse proxy server.
Apr 29 00:58:54 domain.co systemd[1]: Unit nginx.service entered failed state.
Apr 29 00:58:54 domain.co systemd[1]: nginx.service failed.
Пришлось перейти на Apache, в результате потерял удобную функцию кэширования статики в Nginx, а также увеличилось ожидание отклика от сервера на 0.5-0.7 секунд.

Надеюсь, фидбэк поможет сделать вашу панель лучше!

Аватара пользователя
sbury
Сообщения: 817
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение sbury » Сб май 01, 2021 7:56 am

nodejs у станавливается в менеджере приложений. А становится доступным в Web связке apache+nginx

Покажите вывод для certbot этой команды
rpm -qa | grep certbot

если его нет, тогда покажите вывод
yum install -y certbot

stargys
Сообщения: 5
Зарегистрирован: Пн мар 29, 2021 9:44 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение stargys » Вс май 02, 2021 3:08 pm

Добрый день!
1) Да, я устанавливал через менеджер приложений nodejs, но в связке он не появился. Это при обновлении с 1.08xx на новую 1.9.
При новой установке на чистый vps все ок. Бог с ним.

2) Вывод yum install -y certbot

Код: Выделить всё

                                                                                                               
Transaction check error:                                                                                       
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/__init__.cpython-36.opt-1.pyc conflicts between a
ttempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch             
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/__init__.cpython-36.pyc conflicts between attempt
ed installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                   
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/_ast_gen.cpython-36.opt-1.pyc conflicts between a
ttempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch             
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/_ast_gen.cpython-36.pyc conflicts between attempt
ed installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                   
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/_build_tables.cpython-36.opt-1.pyc conflicts betw
een attempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch        
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/_build_tables.cpython-36.pyc conflicts between at
tempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch              
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/ast_transforms.cpython-36.opt-1.pyc conflicts bet
ween attempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch       
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/ast_transforms.cpython-36.pyc conflicts between a
ttempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch             
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_ast.cpython-36.opt-1.pyc conflicts between atte
mpted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_ast.cpython-36.pyc conflicts between attempted 
installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                      
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_generator.cpython-36.opt-1.pyc conflicts betwee
n attempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch          
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_generator.cpython-36.pyc conflicts between atte
mpted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_lexer.cpython-36.opt-1.pyc conflicts between at
tempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch              
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_lexer.cpython-36.pyc conflicts between attempte
d installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                    
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_parser.cpython-36.opt-1.pyc conflicts between a
ttempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch             
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/c_parser.cpython-36.pyc conflicts between attempt
ed installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                   
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/lextab.cpython-36.opt-1.pyc conflicts between att
empted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch               
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/lextab.cpython-36.pyc conflicts between attempted
 installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                     
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/plyparser.cpython-36.opt-1.pyc conflicts between 
attempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch            
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/plyparser.cpython-36.pyc conflicts between attemp
ted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                  
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/yacctab.cpython-36.opt-1.pyc conflicts between at
tempted installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch              
  file /usr/lib/python3.6/site-packages/pycparser/__pycache__/yacctab.cpython-36.pyc conflicts between attempte
d installs of python36-pycparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                    
  file /usr/lib/python3.6/site-packages/pycparser/lextab.py conflicts between attempted installs of python36-py
cparser-2.14-2.el7.noarch and python3-pycparser-2.14-16.el7.noarch                                                                                        
            
Последний раз редактировалось stargys Вс май 02, 2021 9:11 pm, всего редактировалось 2 раза.

stargys
Сообщения: 5
Зарегистрирован: Пн мар 29, 2021 9:44 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение stargys » Вс май 02, 2021 9:10 pm

То, что я писал выше актуально при обновлениях в последних версиях ветки 1.8 вплоть до 1.9.
При установке brainy на чистый сервак тоже не ставился cert

Вывод в консоли - Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

Помогло yum upgrade --setopt=protected_multilib=false --skip-broken

Аватара пользователя
sbury
Сообщения: 817
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: Mariadb 10.5 отсутствует для установки

Сообщение sbury » Пн май 03, 2021 9:43 am

покажите выводы эих команд

Код: Выделить всё

rpm -qa | grep python36
yum remove python36-pycparser
для второй команды пока нажмите N

Ответить