[APACHE] - Error dispatching request to

Обсуждение установки и настройки поддерживаемых вебсерверов, а также работы с ними.
Ответить
irakel
Сообщения: 3
Зарегистрирован: Пт июн 07, 2019 5:45 pm

[APACHE] - Error dispatching request to

Сообщение irakel » Пт июн 07, 2019 5:51 pm

Доброго времени суток всем. Сайт работает в связке Nginx + Apache. Иногда возникает вот такая ошибка, пробовал гуглить, ничего путевого не нашел, как можно исправить? Заранее спасибо!

Код: Выделить всё

[Fri Jun 07 18:33:03.753577 2019] [deflate:error] [pid 3850] [client -:0] AH01386: Zlib error -2 deflating data ((null))
[Fri Jun 07 18:33:03.753736 2019] [proxy_fcgi:error] [pid 3850] (20014)Internal error (specific information not available): [client -:0] AH01075: Error dispatching request to : (passing brigade to output filters)

Аватара пользователя
sbury
Сообщения: 475
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: [APACHE] - Error dispatching request to

Сообщение sbury » Пт июн 07, 2019 6:59 pm

покажите вывод

rpm -qa | grep zlib
rpm -qa | grep httpd

irakel
Сообщения: 3
Зарегистрирован: Пт июн 07, 2019 5:45 pm

Re: [APACHE] - Error dispatching request to

Сообщение irakel » Пт июн 07, 2019 8:21 pm

Код: Выделить всё

[root@vps ~]# rpm -qa | grep zlib
zlib-1.2.11-8.el7.centos.x86_64
zlib-devel-1.2.11-8.el7.centos.x86_64
[root@vps ~]# rpm -qa | grep httpd
httpd24-2.4.39-6.el7.centos.x86_64
httpd24-tools-2.4.39-6.el7.centos.x86_64
httpd24-filesystem-2.4.39-6.el7.centos.noarch

Аватара пользователя
sbury
Сообщения: 475
Зарегистрирован: Вт фев 06, 2018 7:51 am

Re: [APACHE] - Error dispatching request to

Сообщение sbury » Пн июн 10, 2019 7:50 am

если включали оптимизацию для этого сайта, то попробуйте установить в конфиге для nginx этого сайта директиву gzip off; и перезапустите его.

systemctl restart nginx

у себя данную ошибку повторить не можем

irakel
Сообщения: 3
Зарегистрирован: Пт июн 07, 2019 5:45 pm

Re: [APACHE] - Error dispatching request to

Сообщение irakel » Пн июн 10, 2019 11:01 am

Спасибо за ваш ответ. gzip off по умолчанию был прописан, оптимизацию не включал.
Скорее всего проблема в том, что я увеличил timeout в nginx.conf, хоть я до конца и не понимаю как это взаимосвязано.
Буду пробовать решить проблему, если удастся - обязательно напишу в теме.

Ответить